设为首页收藏本站

ROS中国

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 1724|回复: 4

Ikfast安装问题

[复制链接]
发表于 2015-6-17 22:28:32 | 显示全部楼层 |阅读模式
请问ubuntu14.04+ROS indigo 如何安装ikfast和openrave?我按照moveit里的步骤,运行
“sudo apt-get install openrave0.8-dp-ikfast” 时提示 找不到软件包,是不是ubuntu14.04要安装更新版本的openrave,请求大神指导。
回复

使用道具 举报

发表于 2015-6-23 12:54:16 | 显示全部楼层
可以尝试一下
 $ sudo apt-get install ros-hydro-moveit-ikfast
ROS已经integrate moveit了 所以可以直接替换hydro为indigo或者jade 如果有别的问题 可以继续提问
回复

使用道具 举报

发表于 2015-9-21 09:50:12 | 显示全部楼层
不知道楼主的问题解决了没有?
回复

使用道具 举报

发表于 2015-9-21 20:48:11 | 显示全部楼层
楼主更新一下进展呗
回复

使用道具 举报

发表于 2015-9-24 10:04:36 | 显示全部楼层
正在很悲剧的整这个问题,希望楼主能更新一下自己的进展。
我自己的进展如下:

1)sudo apt-get install openrave0.8-dp-ikfast 此路不同,不知原因
2)版主的回答只是解决了插件生成的问题,而运动学封闭解的cpp文件生成仍然有赖于上面的ikfast工具
3)绕道而行,git openrave0.8的源码编译,不行
4)再次绕道而行,git openrave0.9的源码编译,通过,并成功生成封闭解的cpp文件,悲剧的是生成插件的时候表示只支持0.8版本生成的cpp

目前此问题仍在困扰中
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|ROS中国论坛    

GMT+8, 2017-3-24 15:58 , Processed in 0.179661 second(s), 18 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表